36 lines
1020 B
Makefile
36 lines
1020 B
Makefile
# Makefile - hhl - /usr/ports/lang/gcc12
|
|
# Copyright 2022 Nathan Fisher <nfisher.sr@gmail.com>
|
|
#
|
|
comment = The Gnu compiler collection
|
|
distname = gcc
|
|
pkg_name = gcc12
|
|
pkg_version = 12.2.0
|
|
pkg_homepage = https://gcc.gnu.org/
|
|
pkg_license = gnu-gpl-v3
|
|
pkg_maintainer = jeang3nie@hitchhiker-linux.org
|
|
remote_site = gnu
|
|
sha512_sum = e9e857bd81bf7a370307d6848c81b2f5403db8c7b5207f54bce3f3faac3bde63445684092c2bc1a2427cddb6f7746496d9fbbef05fbbd77f2810b2998f1f9173
|
|
include ../../mk/ports.mk
|
|
include config.mk
|
|
include provides.mk
|
|
|
|
ifeq ($(enable_fortran), 1)
|
|
fortran = ,fortran
|
|
endif
|
|
ifeq ($(enable_go), 1)
|
|
golang = ,go
|
|
endif
|
|
ifeq ($(enable_objc), 1)
|
|
objc = ,objc
|
|
endif
|
|
ifeq ($(enable_objcxx), 1)
|
|
objcxx = ,obj-c++
|
|
endif
|
|
|
|
config_opts += --enable-languages=c,c++,lto$(fortran)$(golang)$(objc)$(objcxx)
|
|
config_opts += --disable-multilib
|
|
config_opts += --disable-bootstrap
|
|
config_opts += --with-system-zlib
|
|
|
|
include ../../mk/targets.mk
|